Degraded service

Incident Report for ZenHR

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 14:43 GMT+03:00

Update

We are continuing to investigate this issue.
Posted Apr 02, 2026 - 13:01 GMT+03:00

Investigating

We are experiencing an issue which is causing a degraded service.
We are investigating the issue ..
Posted Apr 02, 2026 - 09:40 GMT+03:00
This incident affected: app.zenhr.com (ZenHR / App Backend).